Really Sony??
Posted by Mystic Worlds [HTML][XML][PERM][FULL] on 12 December 2011, 11:26 am
Way to take the wind out of my sails. I logged into EQ2X real quick to check on something and all was fine. I try logging back into because I I'd forgotten to mail something to an alt but an update starts. The update completes - EQ2X icon is gone, EQ2 launcher is there and patching. When it's done it asks me to reset my password which I do but I'm still confused as to what's going on. I see a link to a posting about a New Launcher and New Launcher FAQs. BOTH LINKS GO TO DEAD LOCATIONS (505 errors). Great. When the patcher allows me to log back into the game all my characters are gone? Uh??? I do a quick Google search to see that EQ2 has gone completely free to play and they are merging X and Live servers. An email to account holders would have...


· Older Entries >>

Show: [ALL] [NEWS] [BLOGS] [PODCASTS]

Updated Today:
A Green Mushroom [HTML] [XML] [FULL]
Bethesda Blog [HTML] [XML] [FULL]
DDOcast [HTML] [XML] [FULL]
Engadget Gaming [HTML] [XML] [FULL]
Massively Overpowered [HTML] [XML] [FULL]
mmocam! [HTML] [XML] [FULL]
MmoQuests.com [HTML] [XML] [FULL]
Reign of Gaming [HTML] [XML] [FULL]
Tobold [HTML] [XML] [FULL]
Welshtroll [HTML] [XML] [FULL]
Updated this Week:
Bioware TOR Dev Blog [HTML] [XML] [FULL]
Lineage II [HTML] [XML] [FULL]
Mystic Worlds [HTML] [XML] [FULL]
Updated this Month:
Blue Kae [HTML] [XML] [FULL]
MMORPG.COM News [HTML] [XML] [FULL]
Morphisat's Blog [HTML] [XML] [FULL]
Ogrebear's Thoughts [HTML] [XML] [FULL]
Raph Koster [HTML] [XML] [FULL]
The Old Republic News from Bioware [HTML] [XML] [FULL]
The Ramblings of JoBildo [HTML] [XML] [FULL]
Wolfshead Online [HTML] [XML] [FULL]
Zen of Design [HTML] [XML] [FULL]